sábado, septiembre 03, 2011

Eclipse y Archlinux

Luego de estar cerca de dos años desarrollando en .NET las cosas del destino me llevaron a retornar al mundo Java J2EE. Ahí, por las herramientas del trabajo usadas para la sincronización de librerias, escritura de código, y sobre todo separación de los proyectos, tuve que empezar a usar (y apreciar) a Eclipse, el proyecto comunitario a cargo del desarrollo de una plataforma para la fabricación de soluciones de calidad industrial, comercial, robusta, altamente integrada, supercalifragilistica espialidosa, que es más conocido como Eclipse IDE.
Como ex-usuario de Netbeans, siempre asocie a eclipse como un tanque a pedales, pesado, lento, hambriento de recursos, y tedioso al tener que esperar que se ejecuten procesos en cadena. Hoy sigo pensando igual, sin embargo, los super poderes de Eclipse vienen de la alta capacidad de mutación que posee el entorno. Es el Firefox de los IDES para Java.

Como ya describí, un atributo destacado por el proyecto Eclipse es la robustez, sin embargo, al instalar la versión oficial (Eclipse versión Helios, compatible con JBoss Tools) en mi sistema Archlinux, y luego de ejecutar la aplicación, y curiosear los menús. Ingreso a la opción Eclipse Marketplace y... CRASH.

El motivo de que, como dirían los colegas ibericos, pete, es que Archlinux tiene una versión de XulRunner muy nueva, no compatible con el módulo web browser usado en Eclipse Helios. La solución es cambiar el browser por WebKit. Para ello agregué los siguientes parámetros al archivo eclipse.ini, y lo solucioné:

-Dorg.eclipse.swt.browser.XULRunnerPath==/usr/lib/xulrunner-6.0/
-Dorg.eclipse.swt.browser.UseWebKitGTK=true

1 comentario:

  1. que bueno que te hayan dejado volver a usar Arch :-D

    Hay que ponerle unos flags de uso máximo de memoria al eclipse o si no se pone a swapear como condenado.

    Que bueno que vuelvas a escribir.
    Saludos,

    ResponderEliminar

Su comentario es bienvenido y agradecido